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What’s New in ProtaStructure 2019 – Quick Summary 

ProtaStructure 2019 is a fantastic new release containing many new features and enhancements for you 
to enjoy. Key highlights include: 

➢ New Member Design Diagrams 

The member design diagram is completely re-developed using the latest technology. The result is a 
very user-friendly interface with powerful interrogation functions to review forces including new 
member deflections plots. Diagrams shown are customizable and very accurate providing superior 
stationing for design, numerical integration and enveloping. New diagrams interface offers superior 
visualization with zoom, pan and stretch tools.   

➢ New ‘Material and Section Effective Stiffness Factors’ 

The Section Stiffness Factors input table is enhanced to cover different section modifiers for 
different members in different degrees of freedom.  This provides user with more refined control 
over the effective stiffness (cracked), including new settings for basement walls & coupling beams 
and  separate in-plane and out of plane stiffness settings for shear walls and slabs.  

➢ Ability to Use Cracked Sections for Load Cases 

Each load case can now be configured to use either cracked or uncracked sections for a given 
combination. This feature is necessary for advanced seismic analysis requirements (for most leading 
earthquake codes) as well as wind load or temperature loading which requires the assumption of 
cracked section properties. Two separate stiffness matrices are formulated for the analysis, run 
concurrently and enveloped for design. 

➢ New Member Type: Coupling Beam 

A new type of beam is introduced: ‘Wall Coupling Beam’.  Coupling beams are used to link shear 
walls for increased stiffness to resist large lateral loads, e.g. seismic and wind loads. Checks are 
performed to validate this system to seismic codes of practice.  

➢ New Member Type: Basement Wall (Meshed) 

A new type of wall is introduced: ‘Basement Wall’. This enables special consideration for basement 
walls in seismic analysis & design, where the participation of the basements mass in the dynamic 
analysis is varied. These results are run concurrently and combined in accordance with the relevant 
seismic code of practice. This is a unique feature which reduces the number of analytical models 
which need to be considered for buildings with basements to just one model running all analytical 
variations in one analysis run. 

➢ Purlins and Girts with Sag rods 

Sag rods can now be inserted in ProtaStructure. They are used to reduce bending moment in purlins 
and girts as well as acting as lateral supports against local buckling. Sag rods are always assumed to 
be pinned frames in building analysis.  

➢ Section Manager Interface & Enhanced Steel Database  

The Section Manager has been enhanced, making selection of members with different material & 
shapes, easier and faster. The steel database has been enhanced & expanded to include many 
country specific sections including Japanese sections.  
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➢ New Built-Up Steel Type: Cross, T & L  Shapes 

The ‘Built Up Steel’ type have been expanded to include cross (+), tee (T) & angle (L) shapes. With  
‘Built Up Steel’, you can model non-standard steel sections not available in any of the country steel 
database.  These built up steel column and beam can be exported to ProtaSteel as well.  

➢ New International & Country Specific Code of Practices 

ProtaStructure now supports American codes of practice for steel and concreate design together 
with associated loadings codes. This includes comprehensive support for Seismic loading, analysis, 
design and detailing including sophisticated checks for complex topics like building irregularities, 
strong column and weak beam design philosophy, and beam column joint shear checks.  Regional 
variations covering detailed loading and design rules for Indonesia and the Philippines are also 
introduced.  

➢ Steel Design Enhancement  

Steel design is greatly enhanced and includes new design interfaces for purlin, girt & braces and new 
design diagrams which automatically detect restraint conditions and buckling lengths for more 
economical design. Steel members are checked for pass / failure status and the most critical 
Utilization Ratio (UR) reported. You can change the section sizes in the interactive design & new 
sections will be automatically checked.  

➢ Enhanced Visual Interrogation 

Visual Interrogation has been further enhanced to include the Steel Design Status and Steel 
Utilization Ratios for quick review of design efficiency. 

➢ Transit columns/walls are displayed on all relevant plan views 

Transit columns or shearwalls (Len Storey= 2 or more) are now displayed on all plan views of the 
storeys they are passing through. They are displayed in a lighter ghost color in the plan view of the 
passing storey. This greatly ease modeling speed and accuracy; it is a highly requested feature 
especially for steel modelling.  

➢ Automatic Wind Load Calculator  

The new wind load calculator automatically determines wind forces in accordance with the chosen 
wind code and applies it the building structure. This greatly increases productivity as values need 
not be manually calculated & entered. The wind code of practices covered are BS6399-2(1997), 
MS1533(2002), EN1991-4(2005) & ASCE7(2010). 

➢ New 64-Bit Advanced Solver  

A new advanced 64-bit solver has been introduced which more efficiently solves both small and 
extremely large models. This also includes a new post analysis checks summary for quick validation 
of analysis results against code-based checks including building displacement, seismic and loading 
validation. 

➢ Enhanced Revit Integration   

ProtaStructure supports bi-directional links with latest version Revit Structure 2019; greatly 
enhancing project coordination and workflow. Model changes can be synchronized and tracked both 
in Revit and ProtaStructure. Round-tripping between Revit to Protostructure is greatly enhanced. 
The Integration Status will color code which members are new, changed, unchanged or deleted.  A 
detailed list explaining these changes is also provided. 
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➢ IFC Export 

ProtaStructure models can now be exported to IFC format using ‘IFC2x3, Coordination View Version 
2.0’. IFC File format is used by many other leading Building Information Modelling (BIM) platforms 
including Autodesk Revit, ArchiCAD, Bentley and Tekla Structures.  This enhances Prota’s standing as 
a leading collaborator and provider of advanced BIM technology. 

 

What’s New in ProtaDetails 2019 

ProtaDetails 2019 contains many completely new features and significant enhancements: 

➢ New RC slab cross sections with reinforcement detailing  

Reinforced slab cross section can be created with reinforcement detailing.  In ProtaDetails, cut 
sections anywhere along the layout plan drawing and position it anywhere within the drawing sheet.  

➢ New Global Options Interface  

Drawing and detailing options are now classified under a single interface; allowing easy global 
control on how the drawings are produced.  

➢ New Rebar Label Settings 

Rebar label settings has been enhanced to allow for more user-defined options for arrow leaders 
(pointing to rebars) and dimensions arrows. This offers greater flexibility for users to produce high 
quality drawings to their company standards.   

➢ Enhanced Column & Beam Detailing Settings  

Numerous new column and beam detailing options are introduced to enhance the quality of 
drawings.  For column elevations drawings, longitudinal bars can be lapped in the mid-span of the 
column (requirement of some code of practice) & bending of bars (BOB) can be controlled. For 
beam elevation drawings, cantilever top rebar extension lengths can be set based on the cantilever 
length multiplied by a user-defined factor. 

➢ Automatic wall opening detailing  

The reinforcement details are automatically created around the shear wall openings in the wall 
elevation details. The shear wall openings are displayed in both the sections as well as schedules. 

➢ Precision detailing for slanting RC columns, varying column section sizes & slanting RC beams  

Column elevation detailing is greatly enhanced to include slanting (angled) columns and columns 
with varying section sizes.  Longitudinal bar detailing including intelligent curtailment and bar 
cranking follows Eurocode and ACI recommendations for columns with changing dimensions. Any 
beams connected to the columns will be drawn in the elevation as well.  

➢ New Engineering Utilities for quick engineering design & calculation 

A new handy Engineering Utilities is provided for quick engineering design. This includes a calculator 
for concrete cover, rebar anchorage & lap lengths; simple beam analysis tool to calculate maximum 
shear, moment and deflections; hydraulics calculator for uniform flow depth & gradually varied 
flow, etc.   

➢ Enhanced Retaining Wall Module 

The retaining wall module is greatly enhanced and now supports the American ACI318 & ASCE7 
code.  In addition, Eurocode is expanded to cover EC2, EC7 and EC8 with all three design 
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approaches.  There are numerous other improvements including a new design & detailing interface 
where rebars can be edited interactively.  

➢ New Dimension Styles Interface 

Dimension styles interface has been enhanced to easily manipulate both project and externally 
opened dwg dimension styles. All predefined detailing dimension styles can be edited and saved 
along with the project 

➢ Multiple selection of Tables for report generation 

Any table drawn in ProtaDetails can be converted to a report and generated via the Report 
Manager.  

 

What’s New in ProtaSteel 2019 

ProtaSteel 2019 contains major new features and significant enhancements: 

➢ Intelliconnect for fully automated steel connection design  

IntelliConnect automatically assesses joints to your preferences, batch creates and designs steel 
connections. It covers a wide range of simple, moment, splice and weld connections. It considers 
constructability by intelligently arranging and configuring all the components of the connections 
without user intervention. 

➢ Connection Design Reports 

ProtaSteel 2019 now creates detailed design check reports for the following connections in 
accordance to EC3, AISC (LRFD), AISC (ASD), and BS5950 for all beam to beam & beam to column 
connections and simple base plate connections.  When a connection is inserted, first a guideline 
design is performed. Then, the rigorous design checks are done according to selected code clauses. 
The reports can be created on demand in rich text format (RTF) and can be added to 
ProtaStructure’s report manager for compilation into final design documentation. Design Status 
colors can be seen on model view before report creation. 

➢ Connection Design Summary Table 

A connection design summary table presents an overview of selected connection macros.  This 
includes “Frame Id”, profile types of macro dependents, connection type, capacity ratio of 
connection, design status according to capacity ratio and whether design report of connection is 
created. 

➢ Design Overrides 

This feature allows you to impose your own company standards and preferences if these are higher 
than the auto-design results. For example, you can specify the minimum number of bolts and 
thickness of the plates for a given connection type. 

 

 

➢ Auto Presets 

This feature enables the user to create relations between profile types and connection macro 
presets.  This allows the program to automatically apply a saved “preset” connection to a particular 
profile section.  

➢ User-defined Design Capacity Ratios  
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User can now input predefined minimum shear and axial capacity ratio’s for connection design 
(design force / by maximum member capacity). These ratios will be used for design if actual shear or 
axial forces imported from ProtaStructure analysis are smaller.  Specifying capacity ratios prevents 
unrealistic connection design, e.g. 1 no. of bolt when actual design forces are exceeding small.   

➢ New Truss Apex Gusset Connection  

This connection macro creates & designs an apex truss connection with gusset plate & supports all 
profile types. This macro is available from the Secondary Connections toolbar.   

➢ New Truss End Plate With Gusset Plate  

This macro creates and designs a connection between truss ends and steel columns using end and 
gusset plates. This macro is available from the Secondary Connections toolbar.   

➢ New Truss Apex Connection Macro 

This macro creates a welded Apex connection without design using “I” profiles. 

➢ New Simple Base Plate Connection Design 

This connection macro creates a simple column base plate connection. 

➢ New Beam to (RC) Wall/Column Connection  

This connection macro creates and designs an embedded steel connection between a steel beam 
and a concrete wall or column. This macro is available from the Secondary Connections toolbar.   

➢ New Welded Steel Pipe (Circular Hollow Sections) Connection  

This macro creates steel tubes connections using welds. This macro is available from the Secondary 
Connections toolbar. 

➢ New Embedded Steel Macro  

This connection macro creates a generic embedded steel with anchor bars, which can then be used 
to connect other steel members to reinforced concrete members. 

➢ New Guardrail Macro 

This connection macro creates hand rails on I, U & C beam profiles.  

➢ IFC File Export 

ProtaSteel models can now be exported to IFC format. This facilitates collaboration with many other 
leading Building Information Modelling (BIM) platforms including Autodesk Revit, ArchiCAD, Bentley 
and Tekla Structure and reinforces Prota’s standing as a leading provider of advanced BIM 
technology. 
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Miscellaneous Enhancement & Fixes 

There are many other enhancements & fixes included in ProtaStructure Suite 2019. Click on the links 
below for more details 

• ProtaStruture enhancement & fixes 

• ProtaDetails enhancement & fixes  

• ProtaSteel enhancement & fixes  

• ProtaBIM enhancement & fixes 
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1. New Member Design Diagrams 

The member design diagram is completely re-developed using the latest technology. The result is a 
very user-friendly interface with powerful interrogation functions to review forces including new 
member deflections plots. Diagrams shown are customizable and very accurate providing superior 
stationing for design, numerical integration and enveloping. New diagrams interface offers superior 
visualization with zoom, pan and stretch tools.   

How to Use 

➢ Select a beam on plan view → Right-click → Beam Analysis Results Diagram  

➢ Alternatively, access the Interactive Beam Design → Pick ‘Diagrams’  

 
 

Loads, Diagrams & Deflections 

➢ Display Detailed Values :  

• Checked : A tracing window will appear showing the exact values of the diagrams, eg. shear 
& moment, when the mouse cursor is placed at a particular location along the member.  

➢ Optimize Stations :  

• Unchecked : The diagrams are displayed using default maximum number of stations.  

• Checked : The number of stations will be reduced & optimized to maintain similar accuracy.  

➢ Diagrams :  

• L1/ L2 / L3 : Check to show external slab loads decomposed & user-defined loads on beams 

• N = Axial force ; T = Torsion 

• V2 = major shear ; M33 = major moment ; δ2 = major deflection 

• V3 = minor shear; M22 = minor moment ; δ3 = minor deflection 

Loads, Diagrams 
& Deflections 

Visualization 
Tools 

Loads Cases & 
Combinations 

Display Detailed 
Values 
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➢ Deflection Display Types :  

Deflections are calculated along the member span for each load case and combination. Deflections 
can be displayed in three different ways: 

• Absolute: The absolute rotation and deflection values are used to display the deflected 

shape. 

• Normalized: The absolute shape is normalized with respect to the value calculated at the 

first point. 

• Relative: The deflected shape is normalized with respect to both start and end points. This is 

particularly useful in determining the deflection relative to both ends in serviceability 

checks. 

Visualization Tools & Report 

➢ Horizontal Scale     → Increase or decrease horizontal scale of diagrams 

➢ Default Display Scale     → click to reset to default scale 

➢ Increase / decrease font size   

➢ Default Font Size   → Click to rest to default font size 

➢ Report    → Generate a report in tabular format with / without diagrams.   

 

The same new diagrams are used for columns & walls :  

➢ Select a column or wall on plan view → Right-click → Column Analysis Results Diagram  

➢ Alternatively, access the Interactive Column Design → pick ‘Diagrams’   

Note :  The analysis post processor (Analysis Model and Results Display) is enhanced to utilize the 
new diagram engine. As such, the occasional “RHS Moment Mismatch” warning & failure during 
beam design is completely eliminated.  
 

2. New ‘Material and Section Effective Stiffness Factors’ 

The Section Stiffness Factors input table is enhanced to cover different section modifiers for 
different members in different degrees of freedom.  This provides user with more refined control 
over the effective stiffness (cracked), including new settings for basement walls & coupling beams 
and  separate in-plane and out of plane stiffness settings for shear walls and slabs. 

How to Use 

➢ The Material & Section Effective Stiffness Factors can be accessed via Building Analysis → 

Model Options → Model tab.  
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The table provides refined control over the effective stiffness (cracked) properties  : 

➢ Shearwalls stiffness can be adjusted differently for FE Shell & Frame (Mid-Pier) assumption.  

➢ In-Plane & Out of Plane stiffness can be set separately for shell assumption of shearwalls, 
basement walls and slabs   

➢ Basement Walls & Coupling Beams stiffness is added due to respective new member type. 
These members type is applicable to code-specific seismic analysis, e.g. Turkish code.  

 

Important Notes :  

• The stiffnesses table will only be applied for load cases with ‘Used Cracked Sections’ checked in 
the respective Load Case Editor, except for seismic load cases where cracked sections are always 
assumed.  

• Each seismic code has its own set of default values. If an entered value is different than the 
default, then editor color will turn to orange to inform the user. 

• Building analysis must be repeated each time the effective stiffness factors are changed. 
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3. Ability to Use Cracked Sections for Load Cases 

Each load case can now be configured to use either cracked or uncracked sections for a given 
combination. This feature is necessary for advanced seismic analysis requirements (for most leading 
earthquake codes) as well as wind load or temperature loading which requires the assumption of 
cracked section properties. Two separate stiffness matrices are formulated for the analysis, run 
concurrently and enveloped for design. 

How to Use  

For existing project with load cases and combinations already generated :  

➢ Go to Building Analysis menu → Load Combinations →  Load Cases  

 

➢ Double-click on a load case to access Load Case Editor  

 
 

➢ Check / uncheck Use Cracked Sections  

For new project, it is highly recommended to use the automatic Loading Generator to generate the 
load cases & combinations : 

➢  Go to Building Analysis menu → Load Combinations → Loading Generator 

 
 

 

 

 
 

 

 



    

ProtaStructure Suite 2018 New Features   14 
Updated May 2019 

 
 

• For load cases with cracked sections assigned, stiffness adjustments in Effective Material & 
Sections Stiffness Factors table will be applied; else 100% default stiffness (uncrack) is 
assumed. 

• ‘Use Cracked Sections’ property is always checked for seismic loading because it is always 
necessary to use effective stiffness factors for seismic design. 

• Notional Loading, Wind Loading, Soil Pressure and Temperature loading can be selectively 
configured to use cracked sections. 

• If ‘Use Cracked Sections in All Load Cases’ option is checked then all load horizontal load 
cases will use cracked section properties.  If unchecked, then additional Gc and Qc load cases 
will be created and used in seismic design combinations. 
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Cracked section properties table is included in the ‘Post Analysis Design Checks’ report. 
 
 

4. New Member Type: Coupling Beam 

A new type of beam is introduced: ‘Wall Coupling Beam’.  Coupling beams are used to link shear 
walls for increased stiffness to resist large lateral loads, e.g. seismic and wind loads. Checks are 
performed to validate this system to seismic codes of practice. This  consequently decrease 
overturning effect and improve overall stiffness of a building system. 

How to Use  

➢ Create a RC beam between two shear walls  

➢ In the Beam Properties → Type dropdown → pick Wall Coupling Beam 

 
 
This new beam type enables ProtaStructure to: 

• Use different cracked section properties as dictated by different seismic codes  

• Assess and check the connected wall panels to see if they act as a coupled wall or not.  

• Utilize different design and detailing approach toward these beams  

• Details are shown in the ‘Post Analysis Checks Report’ → Wall / Frame Effects Checks  
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5. New Member Type: Basement Wall (Meshed) 

A new type of wall is introduced: ‘Basement Wall’. This enables special 
consideration for basement walls in seismic analysis & design, where the 
participation of the basements mass in the dynamic analysis is varied. These 
results are run concurrently and combined in accordance with the relevant 
seismic code of practice. This is a unique feature which reduces the number of 
analytical models which need to be considered for buildings with basements to 
just one model running all analytical variations in one analysis run. 

How to Use  

➢ In the Wall Properties, go to 3D tab  

➢ Wall Model drop down → Pick ‘Basement Wall (Meshed)’ 

This new wall type enables ProtaStructure to: 

• Use different cracked section properties as dictated by different 

seismic codes  

• Always use FE Shell elements for these members in the building analysis.  

• Utilize different design and detailing approach toward these walls  
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6. Purlins and Girts with Sag rods 

Sag rods can now be inserted in ProtaStructure. They are used to reduce bending moment in purlins 
and girts as well as acting as lateral supports against local buckling. Sag rods are always assumed to 
be pinned frames in building analysis.  

How to Use  

➢ In Girt Properties →  Geometry → Set up the girts  

 

➢ Pick ‘Sab Rods’  →  Click Insertion Method drop down & pick the options : 

• Auto fit :  Enter the number of sagrods and the spacing will be divided equally. 

• Manual :  Enter irregular spacings separated by comma.  

➢ Enter all other parameters with reference to the help diagram at the bottom.  

 

TIPS :  

• The right-hand diagram refreshes automatically to show the final setup. Scroll the mouse wheel 
to zoom in & out. Right-click and drag to move.  

• Although, physical members of the sag rods are placed in an alternated pattern, the analytical 
model perfectly connects to column/beam lines and insertion points.  
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7. Section Manager Interface & Enhanced Steel Database  

The Section Manager has been enhanced, making selection of members with different material & 

shapes, easier and faster especially steel profiles. The steel database has been enhanced & 

expanded to include many country specific sections including Japanese sections.  

  
 
How To Use: 

➢ Section Manager is accessible from various places of member creation : 

• Beam & Column properties → Section Manager icon  

• Select a column or beam → Right-click → Edit Section / Material 

• Steel Truss / Purlin / Girt / Brace creation dialog   

➢ In the Database tab, choose the material → Concrete / Steel  

➢ Concrete : Pick the concrete Shape → Input the dimensions 

➢ Steel : Pick the Country Database → Pick the Steel Type & Sections 
 

 

8. New Built-Up Steel Type: Cross, T & L  Shapes 

The ‘Built Up Steel’ type have been expanded to include cross (+), tee (T) & angle (L) shapes. With  
‘Built Up Steel’, you can model non-standard steel sections not available in any of the country steel 
database.  These built up steel column and beam can be exported to ProtaSteel as well.  

How to Use  

➢ In Steel Column or Steel Beam Properties → Pick ‘Section Manager’ 

➢ Pick ‘Built Up Steel’ under Database →  Pick a shape icon  
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➢ Enter all the required parameters such as section name & dimensions.  

Note : Cross shape can only be used for columns.  

 

9. New International & Country Specific Code of Practices 

ProtaStructure now supports American codes of practice for steel and concreate design together 
with associated loadings codes. This includes comprehensive support for Seismic loading, analysis, 
design and detailing including sophisticated checks for complex topics like building irregularities, 
strong column and weak beam design philosophy, and beam column joint shear checks.  Regional 
variations covering detailed loading and design rules for Indonesia and the Philippines are also 
introduced.  
International loadings & seismic code are implemented as follows : 

• UBC & IBC (American)  New!  

• SNI 1726-2012 (Indonesia)   New! 

• NSCP 2015 (Philippines)   New! 

• Eurocode 1 & Eurocode 8  (Singapore, Malaysia & UK Annexes) 

• BS6399 (British) 
 
Concrete design is implemented for the following code of practices : 

• ACI 318-2  (American)  New! 

• EuroCode 3 with Singapore, Malaysia & UK Annexes 

• BS8110-1997  (British) 

• TS500-2000 (Turkey) 
 
Steel design is implemented for the following code of practices: 
✓ AISC360-10 (LFRD) (American)  New! 

✓ AISC360-10 (ASD) (American)  New! 

✓ EuroCode 3 with Singapore, Malaysia & UK Annexes  

✓ BS5950 (British) 

✓ TSC 2016 (LRFD & ASD) (Turkey) 

How to Use  

➢ Go to Analysis → Building Analysis dialog → Parameters  
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➢ Under Earthquake Code → Pick Select → Choose required seismic code 

Tips & Notes :  

Following items are supported for Indonesia and Philippines Seismic Codes: 
 

Indonesia SNI1726:2012, IBC Philippines NSCP2015, UBC97 

User needs to pick Spectral Accelerations at 
short period, Ss and 1 sec period, S1 values 
from hazard map using the exact coordinate of 
the project site. 

User needs to select Seismic Zone, Seismic 
Source Type, Closest Distance to Source. Near 
source factors are automatically calculated. 

User decides on the ‘Risk Category’ of the 
building and selects the appropriate values on 
the UI. 

User decides on the Occupancy Category. 
Importance Factor is automatically fetched from 
the code. 

ProtaStructure automatically determines the 
“Seismic Design Category” depending on 
selected Risk Category and acceleration values. 

There is no Seismic Design Category concept in 
NSCP and UBC. Seismic Zone serves the same 
purpose. 

User also selects the proper ‘System Category’ 
and ‘Structural System Type’ for his building. 
Behaviour Factor (R), Overstrength Factor (Ω0) 
and Displacement Scale Factor (Cd) are 
automatically fetched from tables in the seismic 
code. 

User also selects the proper ‘System Category’ 
and ‘Structural System Type’ for his building. 
Behaviour Factor (R) and Overstrength Factor 
(Ω0) are automatically fetched from tables in the 
seismic code. 

If a selected ‘Structural System Type’ is not 
permitted for the current Design Category and 
Building Height, then ProtaStructure will warn 
the user with a message. 
 

 

If a selected ‘Structural System Type’ is not 
permitted for a given Seismic Zone and Building 
Height, then ProtaStructure will warn the user 
with a message. 
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The following are the scope and assumption of the seismic analysis and design : 

• Elastic and Design spectra are automatically calculated. 

• Same EQ Static and Mode-superposition analysis methods are applied. 

• Maximum period of vibration checks are automatically made. 

• Following irregularity checks are automatically made:  

o Torsional Irregularity 

o Extreme Torsional Irregularity (Not needed for NSCP and UBC) 

o Weak Storey 

o Extreme Weak Storey (Not needed for NSCP and UBC) 

o Soft Storey 

o Extreme Soft Storey (Not needed for NSCP and UBC) 

o Nonuniform Mass Distribution 

• Applicability of Equivalent Static Method is automatically checked. 

• Overstrength factors are automatically applied to design forces. 

• If there is a basement in the building, a two-stage approach is used to analyse the building. 

Basement and superstructure are analyzed separately in different load cases and the results 

are combined for the design. 

• Results for cracked and uncracked section analysis can be combined in same design 

combination. 

10. Steel Design Enhancement  

Steel design is greatly enhanced and includes new design interfaces for purlin, girt & braces and new 
design diagrams which automatically detect restraint conditions and buckling lengths for more 
economical design. Steel members are checked for pass / failure status and the most critical 
Utilization Ratio (UR) reported. You can change the section sizes in the interactive design & new 
sections will be automatically checked. 

In line with the expanded scope of steel members, the user interface is enhanced to group concrete 
& steel members modeling & design separately. 

 

 

How to Use  

➢ Go to Steel Design (top menu)  →  Brace / Purlin / Girt Design 

➢ Alternatively, select a brace, purlin on girt → Right-click → Steel Member Design 
 

The design dialog lists down all the members of the group (as shown below) :  

c 

 Concrete Design 
       Steel Design 

c 
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➢ Pick Check All to preform design check for all members 

The result such as Design Status, Utilization Ratio & Governing Check will be updated in both the 
table and diagram view. 

Design results can be grouped or categorized for easy viewing. For example, if there are 
combination of pass and Fail members, grouping by design status is helpful : 

➢ Click & drag Design Status header to the designated row at the top  (as shown below) 
 

 
 

➢ Double-click on specific member to access the detail interactive steel design.  

 

11. Enhanced Visual Interrogation 

Visual Interrogation has been enhanced to include the Steel Design Status and Steel Utilization 

Ratios for quick review of design efficiency. 

Same Interface for Brace, Purlin & Girts 

All members are listed 

Drag a column header here to group 

Utilization Ratio view 

Analysis Diagram View 

Drag ‘Design Status’ header here 
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How to Use  

➢ Go to Visual Interrogation   →  Criteria of Recoloring → Pick Design Status / Steel Design 
Utilization Ratios 

 

12. Transit columns/walls are displayed on all relevant plan views 

Transit columns or shearwalls (Len Storey= 2 or more) are now displayed on all plan views of the 
storeys they are passing through. They are displayed in a lighter ghost color in the plan view of the 
passing storey. This greatly ease modeling speed and accuracy; it is a highly requested feature 
especially for steel modelling.  

In the example Quick Start Guide Steel, the column is modelled in ST02 with spanning two storeys 
(Len Storey=2) to accurately capture the design effective length. This column will be displayed in 
lighter grey color in ST01  (as shown below).  

 

Column 2C1 is modelled 
with Len Storey = 2 

This column will be shown in 
lighter ghost color in storey it is 

passing through (ST01) 
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13. Automatic Wind Load Calculator  

The new wind load calculator automatically determines wind forces in accordance with the chosen 
wind code and applies it the building structure. This greatly increases productivity as values need not 
be manually calculated & entered. The wind code of practices covered are : 

✓ BS6399-2(1997) 

✓ MS1533(2002) 

✓ EN1991-4(2005)  

✓ ASCE7(2010) 

How to Use 

Step 1: Define wind load combinations: 

➢ Go to Building Analysis dialog via Analysis top drop down menu 

➢ In Pre-Analysis tab, click Loading combinations button 

➢ In Load Combination Editor, click Loading Generator button  

➢ In Automatic Loading Editor, go to Horizontal Load Combinations tab > Check Wind 

Loading as shown below 

 

Note : Check “Define Separate Negative Load Cases” if the wind acting from left to right & right to 
left is expected to be different, e.g. irregular shaped building. Additional wind load cases Wx+, Wx-, 
Wy+ & Wy+ will be created.  

➢ Click OK to close Automatic Loading Editor dialog  

➢ Click OK to close Load Combination Editor dialog 

 

Step 2: Calculate and Apply Wind Loads:  

➢ In Pre-Analysis tab of Building Analysis menu, click Wind and Storey Loads button 
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➢ Click Wind Load Calculator in Storey Parameters and Loads dialog  to launch the wind load 
calculator 

 

 

➢ Change the Wind Code in the drop-down list below if required 

➢ Define all parameters in the Parameters tab 

Notes: 
✓ Most parameters are illustrated and explained in the right figure.  

✓ ‘Primary Wind Angle’ can be used to adjust the direction of the primary wind angle. The effective 

building width and length will be calculated accordingly. Direction factor will be applied where 

applicable. 

✓ All other parameters are explained in the respective codes of practices 

✓ If there are basements that are not subjected to wind loads, it can be excluded via Edit Storey 

dialog (Building Setout top menu) → Input No. of Rigid Basements 
 

➢ Click the wind load cases in the Report and Results in the left pane to review the calculated 

wind pressures and wind loads (as shown below) 
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➢ Click Create Report button at the bottom to generate the wind load summary report  

➢ Click Apply at the bottom right to apply the wind loads to the model 

➢ Review the applied wind loads in the Storey Parameters and Loads (as shown below)  

 
Note: The apply wind loads are editable, you may click & edit the applied wind load  

➢ Click OK to close Storey Parameters and Loads dialog 

Step 3: Run building analysis and review the results in Post-Analysis Result Display 

➢ Go to Building Analysis tab, click Start to perform building analysis 

➢ Go to Post-Analysis tab, click Model and Analysis Results Display  

➢ Go to Elements tab, make sure the Loads and Diaphragms in the Nodal Points button group 

are activated (as shown below) 
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➢ Click any wind load case in the Loading tab (on the right panel).  

The applied wind loads will be shown as nodal point loads that are automatically distributed to the 

center of every floor diaphragm and isolated member(s) where applicable. Mz is the twisting 

moment due the wind load & is automatically calculated based on the eccentricity of the center of 

diaphragm & center of rotation multiplied by magnitude of the wind load case.  

Assumptions & Limitations 

1. Irregular buildings on plan (such as C shape, U shape) will be converted to an equivalent 
rectangle. 

2. Wind loads will only be calculated for windward and leeward faces to obtain the net wind 
pressures/loads on each elevation. 

3. This wind load will not, at this stage, support wind calculations of low rise industrial buildings 
where side and roof wind pressure calculations are required. 

4. The number, distance and dimensions of adjacent buildings in different wind directions will be 
taken as an average input and shall be manually calculated by the user. 

5. For building height exceeding 150m to 200m, the calculated wind loads might not be applicable. 
Please refer to the respective code of practice as requirements are different. A wind tunnel test 
should be conducted if necessary.   
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14. Enhancements in Revit Integration  

ProtaStructure supports bi-directional links with latest version Revit Structure 2019; greatly 

enhancing project coordination and workflow. Model changes can be synchronized and tracked both 

in Revit and ProtaStructure. Round-tripping between Revit to Protostructure is greatly enhanced. 

The Integration Status will color code which members are new, changed, unchanged or deleted.  A 

detailed list explaining these changes is also provided. 

• You can import a ProtaStructure model into Revit. It is fast & 
simple because the model is opened directly in Revit; there is 
no intermediary file.  

• The link supports multi-material, e.g. concrete & steel.  

• There is no limitation in geometry, e.g. includes sloping slabs. 

• It is flexible because you can pick and choose what you want 

to import, e.g. particular storeys or member type, i.e. beams 

or columns or slabs.  

• Changes is Revit model can then be exported back to 

ProtaStructure.  The ProtaStructure model will be updated 

(e.g. change of member size) or merged (e.g. 

addition/deletion of members).  

Please note that ProtBIM addon must be installed in the same 

computer where Revit Structure is installed. Please download 

from online help : http://help.protasoftware.com. 

Round-tripping between Revit to Protostructure is further enhanced. When the Revit model is 
changed & re-imported back into Protostructure, the import dialog box allows you to decide 
whether to automatically remove the deleted members in the Revit model. The Integration Status 
will color-code which members are new, changed, unchanged or deleted.    

How to Use  

1. Import a new ProtaStructure to Revit  

➢ In Revit, start a new project using ProtaStructure_Metric_2019.rte template 

 

➢ In Revit, use Prota BIM tab to import a new ProtaStructure model 

 

➢ Browse & select the ProtaStructure model file with extension .Prota 

 

 

 

http://help.protasoftware.com/
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➢ Pick Import options as desired.  

 
 

Note : ‘First Time Import’ will be checked and will be the only option if it is first import to Revit.  
Check the option Import slabs by interior points will avoid slab trimming and overlapping with other 
member issues. 

➢ Pick Import options as desired → Next →  Close 

A model import summary will be shown with a successful import.  
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2. Export to ProtaStructure  (after changes in Revit) 

➢ After successful import, make changes to the model in Revit  

➢ Select Export to ProtaStructure in ProtaBIM ribbon  

 

➢ Select the same ProtaStructure project in Open Project dialog (as item 1).  

 

A “RevitData” sub-folder will be created under selected project folder with new project files 
incorporating the changes.  

➢ Launch ProtaStructure or bring it to front if it is already loaded. 

➢ Ensure the same project is opened  (project name should not be changed) 

➢ Go to File Menu →  Mode/File import → pick Import From Revit Structure 

➢ In Import dialog, choose the desired options → Pick Import  

 

Note :  ‘Update existing model’ will be automatically checked. Check the option ‘Delete if not found’ 
if you want members that are deleted in Revit to be completly removed in ProtaStructure.  

➢ Building Model Check will be triggered. Take note of any errors & Close 

The view will automatically switch to a 3D view with the Integration Status color coding showing 
whether member(s) is new, changed, deleted & unchanged.  
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The Model Integration Details dialog lists more details of the integration.  

➢ Click the “+” sign to reveal more details, example the exact change of member sizes  

The Integration Status view can re-opened via Visual Interrogation → Integration Status 
 

 
 
3. Re-Import (Update) a ProtaStructure model to Revit  

➢ Make changes to the model in ProtaStructure. Once complete Save the project  

➢ Go back to Revit Structure & ensure the same Revit model is opened.  

➢ Go Prota BIM tab → pick Import from ProtaStructure 

➢ Browse & select the ProtaStructure model file with extension .Prota 

In the Import dialog, “Update exiting Model” will be automatically be checked 

➢ Review the import Options → Import 

The round tripping of “update” import and export to & from Revit & ProtaStructure can be repeated 

as many times as you wish.   
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15. IFC Export 

ProtaStructure model can be exported to IFC format using  ‘IFC2x3, Coordination View Version 2.0’. 
IFC File format is implemented by most design software on the market including leading Building 
Information Model (BIM) platforms like Autodesk Revit, Bentley and Tekla Structures.  The main 
purpose is to allow sharing of building information models between various BIM platforms.  
 

How to Use  

➢ Go to File → Model/File Export → Export IFC File” menu. 

 
 

Tips & Notes :  

Coordination View Version 2.0 

The Coordination View targets the coordination between the 
architectural, mechanical and structural engineering tasks during 
the design phase.  

Purpose of Coordination View Version 2.0 

The Coordination View has been the first view definition developed 
by buildingSMART International and is currently the most 
implemented view of the IFC schema. 
 

The main purpose of the Coordination View is to allow sharing of 
building information models between the major disciplines of architecture, structural engineering, 
and building services. It contains definitions of spatial structure, building, and building service 
elements that are needed for coordinating design information among these disciplines. 
The support of round-trip scenarios is excluded from the support of the coordination view. 

How can you use IFC Files? 

IFC File format is implemented by most design software on the market including leading BIM 
platforms like Autodesk Revit, Bentley and Tekla Structures.  
 

IFC communication is not and should not be expected to be as smart as the current bi-directional 
communication between Revit and ProtaStructure. Revit and ProtaStructure communication is a 
high level integration specifically developed with programming interfaces. 
 

In IFC integration, it is up to the destination software to decide on how to interpret the exported 
model. ProtaStructure has no control on the model once the model is exported to IFC. 
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There are some free IFC model viewer such as ‘Solibri Model Viewer’ to view and coordinate IFC files 
: https://www.solibri.com/solibri-model-viewer  
 
ProtaSteel is also capable of creating IFC files. IFC files created by ProtaSteel includes all the 
connections create. An example screenshot of ProtaSteel IFC imported into Revit is shown below. 
 
 

 
 

https://www.solibri.com/solibri-model-viewer
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16. New RC slab cross sections with reinforcement detailing  

Reinforced slab cross section can be created with reinforcement detailing.  In ProtaDetails, cut 
sections anywhere along the layout plan drawing and position it anywhere within the drawing sheet.  

How to Use 

➢ In ProtaStructure, ensure that all the slabs reinforcement has been designed using slab strips. 

➢ Go to Concrete Design →  Load ProtaDetails  

➢ Generate the Form Plan drawing ensuring options to Show Rebars are checked 

 

Tip : More slab detailing options are available tin the Options 2 tab.  

➢ Go to Detail Library (top menu) → Pick Plan Sections  

➢ Alternatively, in the Command line at the bottom, type “FormSection”  

➢ In the Section dialog, input / select the preferred options 

➢ Draw a “section cut” line by clicking on 2 points on the plan view 

 

➢ Click on the desired location to place the section detail  

Tip : Click   (orthogonal) icon right at the bottom to ensure the line is exactly 

horizontal/vertical.   

 

 

Section A- A 

A A 
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17. New Global Options Interface  

Drawing and detailing options are now classified under a single interface; allowing easy global 
control on how the drawings are produced. This is accessible from Settings (top menu dropdown) → 
Options.  
  

 
 
You can navigate from the left side panel by drilling down to each setting. Further, you can quickly 
search for any specific settings by typing in the “Search Settings…” text box. The navigation panel 
will be filtered out for the results as you type. 
 

18. New Rebar Label Settings 

Rebar label settings has been enhanced to allow for more user-defined options for arrow leaders 
(pointing to rebars) and dimensions arrows. This offers greater flexibility for users to produce high 
quality drawings to their company standards.  This is are accessible to Settings (top menu 
dropdown) → Rebar → Rebar Label.  
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19. Enhanced Column & Beam Detailing Settings & Drawings 

Numerous new column and beam detailing options are introduced to enhance the quality of 
drawings.  For column elevations drawings, longitudinal bars can be lapped in the mid-span of the 
column (requirement of some code of practice) & bending of bars (BOB) can be controlled.  
These new options are accessible to Settings (top menu dropdown) → Column Settings → Details 
Drawings → General tab.  
 

 

The beam elevation detail is also enhanced significantly.  Cantilever top rebar extension lengths can 
be adjusted based on a user-defined factor multiplied by the cantilever length. This feature is 
implemented to cater for some user’s preference for this manner of cantilever beam detailing.  
This feature accessible via Settings (top menu dropdown) → Beam Settings →  Steel Bars tab. 
 

 
Note : A minimum length of Inner & External support will be applied if the resultant cantilever 
support length is less than the former.  
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The dimension options of lap & extension (or anchorage) are separated for top and bottom bars to 

cater for different users’ preference. These options are accessible via the Detailing →  Dimensioning 

tab. 

 
 

Important Notes :  

• The column & beam detailing settings are directly inherited from ProtaStructure where the 
exact same settings exist.  

• Any changes to the settings in ProtaDetails will only affect new details; existing beam details 
remains unchanged.  

• Changes in settings in ProtaDetails cannot be saved; it will be discarded when ProtaDetails is 
closed. 

• If you want to save changes, please update the same settings in ProtaStructure. 

• We strongly recommend you review these settings before producing any drawings.  
 
 

20. Automatic wall opening detailing  

The reinforcement details are automatically created around the shear wall openings in the wall 
elevation details. The shear wall openings are displayed in both the sections as well as schedules. 

 

 
 
The reinforcement detailing around the opening are only suggested rebars; no actual design is  
performed by the program.  

➢ The details can easily be amended by selecting any rebar → the Rebar dialog will appear 

where changes to size, length & shape can be done.  
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21. Precision detailing for slanting RC columns, varying column section sizes 
& slanting RC beams  

Column elevation detailing is greatly enhanced to include slanting (angled) columns and columns 
with varying section sizes.  Longitudinal bar detailing including intelligent curtailment and bar 
cranking follows Eurocode and ACI recommendations for columns with changing dimensions. Any 
beams connected to the columns will be drawn in the elevation as well. 
  

 
 

➢ Ensure to tick “General Column Through Storeys” in Options tab of the Column Elevation 

dialog box.  

There is significant enhancement in slanting beam detailing; details are more precise and accurate in 
beam elevation drawings.  
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22. New Engineering Utilities for quick engineering design & calculation 

A new handy Engineering Utilities is provided for quick engineering design. This includes a calculator 
for concrete cover, rebar anchorage & lap lengths; simple beam analysis tool to calculate maximum 
shear, moment and deflections; hydraulics calculator for uniform flow depth & gradually varied flow, 
etc.   

How to Use 

➢ Go to Design Library (top dropdown menu) → Engineering Utilities 
 

 
 
The following is the complete list of the modules and their functions : 

❖ Cover and Anchorage Calculator   
➢ Calculates concrete cover, anchorage and lap lengths 

❖ Hook Length Calculator 
➢ Calculates rebar bending, extension & total hook length 

❖ Rebar Area Calculator  
➢ Calculates provided steel area per meter (e.g. 10H16 @ 100mm spacing) based on required 

steal area 

❖ Unit Conversion 
➢ Converts common engineering units, eg.  Pascal (Pa) → Kilopound Per Square Inch (ksi) 

❖ Simple Beam Analysis 
➢ Calculates maximum shear, moment & deflection for single span beam with various support 

condition such as simple, cantilever & fixed end  

❖ Uniform Flow Depth (Hydraulics) 
➢ Solves for discharge, flow depth, channel width or channel slope for rectangular, trapezoidal 

or circular channels under ‘uniform flow depth’ condition 

❖ Gradually Varied Flow (Hydraulics) 
➢ Solves for discharge, flow depth, channel width or channel slope for rectangular, trapezoidal 

or circular channels under ‘gradually varied flow’ condition 
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23. Enhanced Retaining Wall Module 

The retaining wall module is greatly enhanced and now supports the American ACI318 & ASCE7 
code.  In addition, Eurocode is expanded to cover EC2, EC7 and EC8 with all three design approaches.  
There are numerous other improvements :  
❖ Generated loads can be inspected separately for all parts of the wall for long term and short 

term analysis. 

➢ Go to Loads → Select a Load →  selected load will be colored in red 

 
 
❖ Effect of shelves on lateral earth pressure and fill weights are now applied and is shown in 

detailed loading scheme 
❖ Two different approaches to total failure are introduced; namely Fellenius and Bishop’s methods 

➢ Go to Total Failure → Analysis Method →  Select Fellenius / Bishop’s Method 
❖ New option to have multiple layers of rebars at base plate 

➢ Go to Design Settings → Number of Top Rebar Layers at Base Plate → Select 1/2/3 
 

 
❖ Design approach is changed to be accurately based on reaction/forces at specified sections 

❖ Detailed loadings and design forces at each section can be further inspected  

➢ Go to Design → Pick Section Analysis Detail → Select Position to reveal detail checks 
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❖ New Design interface allows easy visual identification of various rebars  

➢ Go to Design → Pick a Rebar → the rebar will be highlighted in blue in the diagram 
 

 
 
❖ New Detailing interface allows easy visualization and edit of rebars interactively.   

➢ Go to Stem / Base Plate → Pick a Reinforcement →  Edit number / diameter / spacing  
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24. New Dimension Styles Interface 

Dimension styles can be edited using this interface and can be saved along with the project 
➢ You can find it under “Formats > Dimension Styles”  
➢ All the necessary dimension styles for detail generation will come predefined 
➢ Use “+” and “x” buttons to add/remove dimension styles 
➢ Edit them as you wish. When you click “Ok” they will be saved in the project data. There is 

no need to save project or drawing explicitly. 
 

 
 
 

25. Multiple selection of Tables for report generation 

Any table drawn in ProtaDetails can be converted to a report and generated via the Report Manager.  

 How To Use: 

➢ Select a table or multiple select tables (hold down 
CTRL) 

➢ Right-click → Add to Report 

➢ Give it a title → OK 

➢ The report will be created 

This particular report will also be added in the report 
repository Report Manager in ProtaStructure (under 
Other Structural Members) 
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26. ProtaSteel Introduction 

ProtaSteel is a powerful steel detailing module to produce engineering drawings, general 

arrangement drawings & connection details.  The main steel model is transferred seamlessly from 

ProtaStructure to ProtaSteel. In ProtaSteel, you can : 

✓ Create steel connections. Most of the standard connections 

will be auto-designed based on material strength.   

✓ Insert ancillary & secondary such as sag rods, doors & 

windows opening, steel staircase, etc. 

✓ Perform minor adjustment & fine tuning of member position.  

✓ Create engineering drawings, general arrangement drawings and 

connection details. 

How To Use : 

➢ Model, analyze & design the steel structure in ProtaStruture 

➢ Go to Steel Design (top menu) → Load ProtaSteel  

Please refer to the Quick Start Guide in ProtaSteel for further guidance.  

 

27. Intelliconnect for fully automated steel connection design  

IntelliConnect automatically assesses joints to your preferences, batch creates and designs steel 
connections. It covers a wide range of simple, moment, splice and weld connections. It considers 
constructability by intelligently arranging and configuring all the components of the connections 
without user intervention. This results in huge improvement in productivity as it minimizes time 
required to manually create & correct these connections.  
 
 

 
 

Why use IntelliConnect?  

Advanced steel detailing software typically create connections automatically between two elements 
by applying certain rules, i.e. “Rule based joints”. These rules normally include items such as names 
of the profiles, the existence of moment releases or lack thereof, the loads in the elements and 
approach conditions (whether the secondary is approaching the main from the flange side or the 
web side) etc.  
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                        Figure 1               Figure 2 
 
While this feature of “Rule based joints” is beneficial in simple cases where the main and the 
secondary (incoming profile) are the only two profiles present at a joint (see Figure 1 above), it fails 
to deliver for complex joints when more than two elements meet at the same joint (see Figure 2) :   
❖ For complex joints, applying a blind “Rule based joint” would create a huge number of clashes, 

resulting in wasted & unproductive time in manual amendments.  
 
❖ “Rule based joints” will not have the intelligence to 

“auto-shift” the secondary member slightly to 
facilitate a connection. Such requirements are 
commonplace in steel detailing when incoming 
members need to be shifted slightly to avoid clashes 
and make erection possible.  

 
❖ A typical example (see Figure 3) would be the need 

to shift the horizontal bracing in flooring systems 
away from the beam-beam intersection points to 
avoid clashes with connection plate. 

 
 

 
❖ “Rule based Joints” typically do not combine 

incoming elements to create a single common 
connection if the situation demands it.  

 
❖ For example (see Figure 4), two horizontal braces will 

connect to the same point separately, creating a 
clash between the gusset plates, rather than using a 
single common gusset plate.  

 
  
 
 

IntelliConnect is an advanced technology which attempts to address these issues in certain cases 
which are common in building detailing.  These includes “simple cases”, e.g. where there are only 2 
primary elements and “complex cases” where more elements meet at the same node.  
 

Figure 3 

Figure 4 
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Cases covered 

The following “Simple Cases” are covered by IntelliConnect :  
1. Splice connection (Supports whatever profiles are supported by the Splice macro) 

2. Column Base plate with no incoming vertical bracing. (The column needs to be an I section) 

3. A single beam framing into a main beam. The Beams can be I or channel profiles. The type of 

beam to beam connection can be any one of the following 1) The Stiffend end plate 

connection. 2) The Fin plate connection 3) The beam to beam end plate connection. 

4. A single beam framing into a column. The profiles may be I or channel profiles. The type of 

beam to beam connection can be any one of the following 1) The Stiffend end plate 

connection. 2) The Fin plate connection 3) The beam to beam end plate connection. 

5. A single horizontal brace framing into a beam. The horizontal brace may be any profile 

supported by the Bolted gusset or welded gusset macros) 

6. A single vertical brace framing into a column. The vertical brace may be any profile 

supported by the bolted gusset or welded gusset macros.  

7. A single purlin sitting on a beam or truss element. The type of connection may be any 

connection supported by the Purlin/Girt macro 

8. A single girt framing into a column. The type of connection may be any connection 

supported by the Purlin/Girt macro 

9. Creation of batten plates on twin profiles. 

10. Connection of a single purlin passing continuously over a truss top chord or roof beam 

The following complex cases are covered by IntelliConnect :  
1. Two horizontal braces framing into a beam (from any side – web or flange) 

2. Two vertical braces framing into a column (from any side – web or flange) 

3. Truss connecting with more than one truss secondary framing into the truss top or bottom 

chord.  

4. Two purlins sitting on a truss top chord or a roof beam 

5. Two girts framing into a column (either colinear or one from each orthogonal direction ) 

6. Two floor beams framing into a main beam from opposite sides 

7. Combinations of floor beams and horizontal braces framing into each other at the same 

point from both sides  

8. Up to 4 beams framing into a column (two from flange side and two from the web side) 

9. Combination of beams and vertical braces framing into a column 

As far as limitations on profile types and connection types are concerned, the same limitations given 
in the simple cases apply.  
 

How to use 

The following is the summary of how to Intelliconnect :  
❖ The user will first select a single or multiple nodes which holds the information of all elements 

meeting at a single point.  
❖ After which the user simply right clicks and goes into the IntelliConnect context sensitive menu 

and select the type of connections to create.  
❖ For some IntelliConnect  connections however the user needs to select frames and not nodes 

(e.g. simple cases 9 and 10 stated previously) 
❖ Intelliconnect will its “internal classifying algorithm” to connect as many of the nodes selected 

by the user as possible.  
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❖ However, if it encounters a case which is not supported, it will either partially connect the node 
or leave it completely unconnected.   
 

❖ After the process is finished the user can browse through these partially connected or 
unconnected nodes and connect/correct them manually.  

❖ User can browse through these nodes one by one through a navigator.   
 

Purlin Example 

➢ Select the nodes (joints) of the steel structure where you wish to create connection 

Joints are shown as blue dots at the end of the member. For simplicity, you can click and drag a box 
to select all members which will then also select the nodes.  

For illustration purpose, we will create the purlin connections based on the Quick Start Guide Steel 
model.  

➢ Select all the truss members and purlins by left-click a drag a box around them  

 

➢ Right-click → IntelliConnect → Pick Create Purlin Connection 

  

➢ In the Purlin Wizard, choose the preferred type of connection 

➢ For this example, choose “Angle Type” & “Reversed Cleat”  

➢ Input further parameters in the next wizard dialog  →  Run 

➢ AutoConnectLog text file will open → Review its contents as it lists all the connections that 
are successfully / unsuccessfully created 
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How To Use (Beam – Column – Brace Example) 
For illustration purpose, we will auto create a beam – column – brace connection based on the Quick 
Start Guide Steel model. 

➢ Select the joint where beam, column and brace meets 

 

➢ Right-click → IntelliConnect → Pick Create Column/Beam Connection 

Where there is multiple possible connection configuration,  the subsequent dialog allows you to 
choose which connection type to consider and it’s priority. 

 

➢ Pick the connection types to consider →  Adjust the priority using up/down arrow → Next  

The relevant bracing shifting, bracing connection & haunch connecting settings will appear next 

➢ Make desired adjustment  → Run →  Connection will be created 
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28. Connection Design Reports 

ProtaSteel 2019 now creates detailed design check reports for the following connections in 
accordance to EC3, AISC (LRFD), AISC (ASD), and BS5950 :  

• Beam to beam Connections :  End Plate, Stiffened End Plate, Fin Plate  

• Beam to Column Connections :  End Plate, Stiffened End Plate, Fin Plate  

• Simple base plate connections 

When a connection is inserted, first a guideline design is performed. Then, the rigorous design 
checks are done according to selected code clauses.  Reports include both geometric checks and 
capacity checks. In addition, intermediate calculations, references to the appropriate clauses of the 
design code, and corresponding equation are displayed for easy checking.   
 

 
 
The reports can be created on demand in rich text format (RTF) and can be added to 
ProtaStructure’s report manager for compilation into final design documentation. Design Status 
colors can be seen on model view before report creation. 
 

How To Use 

To show the utilization ratio of the connection visually:  

➢ Go to View (top menu)  → Connection Design Ratio Coloring 

The connection will color coded :  Yellow = Not checked/designed; Green = Pass; Red = Fail. 
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➢ Right-Click → Connection Design Reports (or Go to Drawings & Report (top menu) → Connection 
Reports) → Select the desired report :  

• Show Connection Report → Show connection report of selected macro (s) 

• Default Connection Report → Create connection report according to project preference 

• EC3 / BS5950 / AISC_LFRD /AISC_ASD Connection Report → Create connection report for the 
selected code 

29. Connection Design Summary Table 

A connection design summary table presents an overview of selected connection macros.  This 
includes “Frame Id”, profile types of macro dependents, connection type, capacity ratio of 
connection, design status according to capacity ratio and whether design report of connection is 
created. 

How To Use 

➢ Select one or more connection macro 

If no macro is selected, the table will show all supported macros in the model  

➢ Go to Drawings & Reports (top menu)  → Connection Reports → Connection Design 
Summary Table 

 

The top icons from left to right :  

❖ Update →  Refreshes the table 

❖ Show in Model →  Locate & zoom in the selected macro in the model view.  Double-clicking 
on any row will also perform the same function.  

❖ Create Report → Create the connection design report of the selected macro.  Hold down 
CTRL key to multiple select.  

❖ Open Report → Open the selected design report 

To check the connection & generate the report :  

➢ Select the connection by any of these methods : 

• Select the connection macro sign   

• Select any  component of the connection (eg. a 
plate or a bot) → then press “M” 

• Left click and drag a window enclosing the entire 
connection 

TIP : Hold down CTRL to multiple select 
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30. Design Overrides  

This feature allows users to impose minimum parameters to a connection if these standards are 
higher than auto-design results. For example, minimum number of bolts can be specified. This will 
result in practical & constructible connections; saving many hours of design review and 
amendments.  
❖ In many cases the design shear in simple steel beams are quite low (since the beam size is 

usually governed by span moments). The auto-design of the connection will likely result in very 
few numbers of bolts, very small plate thicknesses and / or very small weld sizes as these still 
passed recommended design formulas.  

❖ Obviously, such design is not acceptable. Typically, the steel detailer will increase the number of 
bolts or plate thickness or weld size to a reasonable number. However, such manual 
intervention is unproductive and defeats the purpose of automated design.  

❖ To resolve this issue, the ProtaSteel provides an override file to specify minimum parameters 
such as number of bolts and plate thickness.   

❖ This feature applies to the following connection macros :  
1. Stiffened End plate macro (Both for beam to beam and beam to column connections) 

2. Fin plate macro (Both for beam to beam and beam to column connections) 

3. End plate macro (Both for beam to beam and beam to column connections) 

 

How To Use 

The design overrides are defined in text files in the preference folder :   

➢ Click on ‘Open Preferences Folder’ (top menu)   

➢ Open the file “Simple Beam Connections Design Overrides.txt” 

The structure of this file is as shown below. 

 
 

➢ Modify & Save this text file to force the program to use “higher” values of selected design 
parameters than those suggested by the design formulas.  

The program will only use these values if they are “higher” than the that proposed by the code 
calculations.  

The Database Editor can also be used to edit the text file in ProtaSteel :  
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➢ Go to Tools → Databases → Profile Database Editor  

 
 

1. Database Files 

➢ Select the file to view or edit →  ‘Simple Beam Connection Design Overrides’ 

2. Content 

➢ Select the row to edit 

➢ To add new  row, pick the  sign / To delete a row, pick the   sign 

3. Key / Value 

➢ View or change the values of the key  

➢ Saves Changes or Discard & Refresh 

4. File Comments 

➢ Read the notes to understand key abbreviations & how to use it  

 

31. Auto Presets  

This feature enables the user to create relations between profile types and connection macro 
presets.  This allows the program to automatically apply a saved “preset” connection to a particular 
profile section.  

❖ All connections macro supports “Macro Presets” where user can save a particular connection 
parameters & configuration and reuse it elsewhere without having to enter all the values again.   

❖ For example, for the haunch connection, the user may want to save different parameters for 
each profile that is commonly used, example for UC152x152, UC203x203 & UC254x254.  

❖ However, as the number of presets increases, it becomes increasing difficult & cumbersome to 
manage as the user still need to recall the correct preset to apply with every connection macro. 

To resolve this issue,  the “Auto-Preset” feature is developed make application of these pre-sets 
automated; thus increasing productivity and eliminating errors.   
 

 

1 

2 

3 

4 
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How To Use 

For illustration, we will use the connection macro ‘Column base plate without design’.  The 
objective is set up a fixed column base plate for a fixed base and hinged column base plate for a 
hinged base.  
 

 
 
Note : This connection macro does not perform any design – it’s is entirely up to the user to set up 
this connection. 

➢ Right-Click on  ‘Column Base Plate Macro Without Design’   → Input/change as below 

 

 

 

 

 

 

 

 

 

Fixed Hinged 
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➢ Go to Maco Preset tab → Save As → Type “UC_Hinge”  → Close the dialog 

 

The intention is this macro connection will be automatically used for column with this UB profile and 
hinged at base.  

➢ Right-Click on  ‘Column Base Plate Macro Without Design’  → Input / change as shown 
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➢ Go to Macro Preset tab → Save As → Type “UB_Fixed”  → Close the dialog 

➢ Click on ‘Open Preferences Folder’ (top menu)  

➢ Double-click on file ‘Base Plate Without Design Macro Preset Override.txt’ to open it 

➢ Ensure the highlighted part is typed as shown below. Use “tab” to as separator.  

  

The above means that whenever there is a UB200x150x30, use macro preset “UB200_Fix” if the 
base is fixed and use “UB200_Hinge” if the base is hinged.  

➢ Go back the 3D view → Double-click on one of the column base joint  

 

➢ Click ‘Column Base Plate Macro Without Design’ → Select the column above 

The hinge column base connection will be created.  

In the Joint dialog, it shows that the joint in 
restrained in both translation (U1,U2,U3) as well 
as rotation (R1, R2, R3). 

The joint restraint is directly transferred from 
ProtaStructure.  

To change the joint to hinge :  

➢ Uncheck “R1”, “R2” & “R3” 

➢ Close the Joint dialog 
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➢ Click ‘Column Base Plate Macro Without Design’ → Select another column with default fixed 
restraint.  

The fixed column base connection will be created.  

TIP : The preset files can also be edited via Tools → Databases → Profile Database Editor 

Each macro preset is saved with an extension of “mpr”. Each time a preset is saved, a file with an 
extension of mpr is created in the relevant directory.  
 

 

32. User-defined Design Capacity Ratios  

User can now input shear and axial capacity ratio for connection design (design force / by maximum 
member capacity). These ratios will be used for design if actual shear or axial forces imported from 
ProtaStructure analysis are smaller.  Specifying capacity ratios prevents unrealistic connection 
design, e.g. 1 no. of bolt when actual design forces are exceeding small.   

How to use 

➢ Double-click the member is critical to the connection design  
➢ Go to Detailing Definitions tab in Profile dialog → Input Shear / Axial Capacity Ratio 

 

 
 
➢ Go to Analysis tab to check the geometric properties from ProtaStructure 
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33. Truss Apex Gusset Connection  

Apex Truss Gusset Connection macro creates & designs a connection between two top chords and 
secondary truss elements with gusset plate. This macro is available from the Secondary Connections 
toolbar.   
 

 

 
 
This macro supports connection with 1 to 3 secondary profiles. These secondary profiles can be 
welded or bolted, and their profiles and orientations can be different. However, profile type and 
orientation of top chord elements need to be the same. Selection order of secondary profiles is also 
important such that it determines which elements are pulled back and in what order. 

Cases Covered 

Apex Truss Gusset Connection Macro supports to cases that connected by several apex and 
secondary profile types. For secondary trusses; L, U, square tube, round tube and twin profiles are 
supported. For Main apex trusses; in addition to secondary profile types I profile is supported. 

 

34. Truss End Plate With Gusset Plate  

This macro creates and designs a connection between truss ends and steel columns using end and 
gusset plates. This macro is available from the Secondary Connections toolbar.   
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Secondary profiles are connected to gusset plate with welded connection and their section type and 
orientation can be different. Main column profile and end plate are connected with bolted 
connection. Selection order of secondary profiles is imported. Upper secondary profile needs to be 
selected first. 

Cases Covered 

Truss end plate with gusset plate macro supports to cases that connected by several secondary 
profile types. For secondary trusses; L, U, square tube, round tube and twin profiles are supported. 
For Main column; I profile is supported. 

 

 

35. Truss Apex Connection Macro  

This macro creates a welded Apex connection without design using “I” profiles. This macro is 
available from the Secondary Connections toolbar.   
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36. Simple Base Plate Connection 

This connection macro creates a simple column base plate connection.  This macro is available from 
the Secondary Connections toolbar.   

 

 
 
 

37. Beam to (RC) Wall/Column Connection  

This connection macro creates & designs an embedded steel connection between a steel beam and 
a concrete wall or column. This macro is available from the Secondary Connections toolbar.   
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38. Welded Steel Pipe (Circular Hollow Sections) Connection  

This macro creates steel tubes connections using welds. This macro is available from the 
Secondary Connections toolbar. 

 

 

39. Embedded Steel Macro  

This connection macro creates a generic embedded steel with anchor bars, which can then be 
used to connect other steel members to reinforced concrete members. This macro is available 
from the Secondary Connections toolbar (as shown below).  
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40. Hand Rail Macro 

This connection macro creates hand rails on I, U & C beam profiles. This macro is available from the 
Secondary Connections toolbar.   

 

 
 

41. IFC File Export 

ProtaSteel models can now be exported to IFC format. This facilitates collaboration with many other 
leading Building Information Modelling (BIM) platforms including Autodesk Revit, ArchiCAD, Bentley 
and Tekla Structure and reinforces Prota’s standing as a leading provider of advanced BIM 
technology. 

How to use 

➢ Select objects to be exported as IFC file format.   

If no object is selected, then all objects will be exported.  

➢ The File → Export →  IFC Export  

 

➢ Click ‘…’  to specfy the file name and location to export  

➢ Check the desired export options → Export 
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42. ProtaStructure Enhancement & Fixes  

✓ Resolved out of memory issue for large models. 

✓ Various enhancement of pilecap design to arrive at an economical solution  

✓ Steel member design is enhanced to overcome some reported issues of crashes & inconsistencies 

✓ “D” square mesh (fabric) added with all commonly used bar diameters  

✓ Cannot insert beams when axis of insertion is exactly at global origin 

✓ Rigid link erroneously generated at the bottom of discontinuous mesh walls – Fixed 

 

43. ProtaDetails Enhancement & Fixes 

✓ Undo & redo functionality introduced for all Cad and Intelligent Cad operations 

✓ Drawing sheets with horizontal title blocks at the bottom added   

✓ Leader size and presentation added in Options > Rebar Labels  

✓ Slab design settings does not transfer consistently to ProtaDetail  - Fixed 

✓ Similar beams listed wrongly in concrete rebar schedules – Fixed 

✓ Beam Quantity table not scaled with drawing scale – Fixed 

 

44. ProtaSteel Enhancement & Fixes 

✓ Member labels are now exported in “User Defined 3” field in CDFX file. These labels are used in 

Connection Report generation for better user experience. These fields can be annotated (in the 

model) using "Edit > Create Annotation" field.  

✓ Splice connection is now working for truss elements as well. 

✓ ProtaStructure element ID numbers are now displayed in Frame Element Property Editor title bar 

and in “General Definitions” tab. This ID is also used in Connection Design Reports to refer to 

frame elements. 

✓ DXF files can now be imported into model 

✓ Slanted columns imported with wrong rotation  - Fixed 

✓ Geometry of object is not valid error during import of ProtaStructure model – Fixed 

✓ Anchor bolt, shear key, and rag bolt types are added to Embedded Steel Connection macro. 

✓ After the first export from ProtaStructure to ProtaSteel, when an object is selected, the view was 

zooming out to model extents - Fixed 

45. ProtaBIM Enhancement & Fixes  

✓ ProtaBIM now recognizes and uses built-in Revit families for standard shapes. (Rectangular 

Concrete Column, Beam, UC Column, UB Beam, CHS, RHS, SHS etc.) 

✓ Family subtypes are extended in the template. Users can see more types under a certain famiy 

(only for built-in) 

✓ Abandoned ProtaStructure families are also recognized, in case an existing model is using them. 

✓ Usage of standard families offers flexibility, so that users do not have to stick with ProtaStructure 

families if the model is started from Revit.  
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